java – Android需要编译器合规性级别5.0或6.0。找到’1.7’而不是。请使用Android工具>修复项目属性

原创 287865  2019-08-27 04:00 

有没有人有类似的问题,我导入Android项目,我得到错误像

   [2011-10-03 17:20:09 - screen] android requires compiler compliance level 5.0 or 6.0. found '1.7' instead. please use android tools > fix project properties.
[2011-10-03 17:21:55 - app] android requires compiler compliance level 5.0 or 6.0. found '1.7' instead. please use android tools > fix project properties.
[2011-10-03 17:21:59 - app] android requires compiler compliance level 5.0 or 6.0. found '1.7' instead. please use android tools > fix project properties.
   

我有错误删除所有@override上面功能。我有Windows 7 x64,jvm7 x64。有没有人知道什么是错的?(我做了android工具 - >修复项目属性,但没有帮助)

最佳答案:


那不是问题,杰克。 android sdk不是x64,但可以正常使用x64 jvm(以及x64 eclipse ide)。

正如helios所说,你必须将项目兼容性设置为java 5.0或java 6.0。

要做,2个选项:

  1. 右键单击您的项目并选择 "android tools -> fix project properties" (如果这不起作用,请尝试第二个选项)
  2. 右 - 单击您的项目并选择 "properties -> java compiler" ,然后选中“启用项目特定设置”并从“编译器符合性设置”选择框中选择1.5或1.6。
本文地址:https://www.hedasudi.com/3461.shtml
版权声明:本文为原创文章,版权归 287865 所有,欢迎分享本文,转载请保留出处!